Back to overview
Issue with Textify
Jun 19 at 01:36pm EDT
Affected services
Textify
Resolved
Jun 19 at 01:36pm EDT
The Textify app is offline - our team is working diligently to identify and correct the problem
More updates to follow
Affected services