Back to overview
Issue at Datacenter
Apr 12 at 11:08am EDT
Affected services
Accuro Fax
E2Fax
Resolved
Apr 12 at 11:08am EDT
UPDATE: Our team is onsite and is working on the issue. More updates to follow.
Our datacenter is experiencing a partial outage which is affecting inbound and outbound faxes. Faxes are processing however, you may experience some delays. More updates to follow. Thank you for your patience.
Affected services