Back to overview

Issue with Fax Services

Apr 08 at 03:06pm EDT
Affected services
Accuro Fax
E2Fax

Resolved
Apr 08 at 03:06pm EDT

We are currently investigating reports of inbound errors.