Back to overview
Fax inbound issue
Mar 17 at 12:01pm EDT
Affected services
Accuro Fax
E2Fax
Resolved
Mar 17 at 12:01pm EDT
Our systems admin team is investigating an inbound issue. More updates to follow
Affected services
Resolved
Mar 17 at 12:01pm EDT
Our systems admin team is investigating an inbound issue. More updates to follow
Affected services