Back to overview
Resolved
Yesterdays's Fax Issues
May 26, 2026 at 4:17pm UTC
Affected services
Accuro Fax
Resolved
May 26, 2026 at 4:17pm UTC
We believe the issue to be resolved. Faxes are sending normally. We will continue to monitor to ensure stability.
We have temporarily restricted uploading and downloading of faxes while the servers work thru the backlog.
^ps
We are experiencing delays due to the back log from yesterday - We are working to resolve this as expeditiously as possible.
^ps
Due to the issues processing faxes yesterday, we do expect higher volumes of faxes. As a result faxes may take longer than normal to process.
Affected services