Back to overview
Issue with Primary Carrier
May 4, 2026 at 6:42pm UTC
Affected services
Accuro Fax
Resolved
May 4, 2026 at 6:42pm UTC
Re-routing is complete and appears to be working well.
Currently working with our primary carrier to determine the issue.
We are experiencing an issue with connectivity to our primary carrier.
We are currently in process of re-routing to secondary carriers.
More updates to follow.
Affected services