Back to overview
Intermittent Connection issues to the Accuro Fax Platform
Apr 1, 2026 at 4:57pm UTC
Affected services
Accuro Fax
Resolved
Apr 1, 2026 at 4:57pm UTC
We are aware of an ongoing incident in which there are intermittent connection issues to Accuro Fax.
Our systems admin team is currently investigating.
Update: This issue has been resolved and we are monitoring the status. Some faxes may take longer to process as the system works through backlog.
We are aware of an ongoing incident in which there are intermittent connection issues to Accuro Fax.
Our systems admin team is currently investigating.
Affected services