Delays with Accuro Fax
Resolved
Jan 05 at 07:04pm EST
This issue is resolved. Thank you for your patience.
UPDATE: Our security partners are actively making progress on this issue and faxes are flowing at a much higher level. We will continue to monitor and advise as we deal with this issue.
We are currently experiencing an ongoing distributed denial-of-service (DDoS) attack. Fax services remain operational, however, you may experience slower-than-normal processing times and a higher failure rate. Our technical teams are actively mitigating the issue and working to maintain service stability. We will continue to monitor the situation closely and provide updates as appropriate.
Please note these kinds of attacks are typically aimed at interrupting services and should not pose a threat to the security of your data. Thank you for your patience and understanding.
Due to extremely high volume, outbound faxes are currently backlogged. Things are processing normally and processing times will return to normal shortly.
Affected services