Back to overview

Issue at our datacenter

Oct 30 at 09:55pm EDT
Affected services
Accuro Fax
E2Fax

Resolved
Oct 30 at 09:55pm EDT

We are currently investigating an issue at our data center which is affecting our fax platforms.

More info to follow