Back to overview

Issue with Accuro fax

Sep 11 at 12:47pm EDT
Affected services
Accuro Fax

Resolved
Sep 11 at 12:47pm EDT

UPDATE: Accuro has implemented a fix. As a result outbound faxes are now being sent.

Given the backlog, there may be a delay in processing.

Please refer to the Accuro status page for more information.

https://status.qhrtech.com/

Faxes are being received as normal and will be available for download when the Accuro service is restored.