Back to overview
Issue at 911 Data Center
May 13 at 10:48am EDT
Affected services
www.unitelogin.net
mt1.unitelogin.net
sipster.voiphighway.com
Resolved
May 13 at 10:48am EDT
We have received notification from the 911 Data Center that they are experiencing an issue with inbound calls to them. They are working on the issue now. If you need to call 911 - please use your cell phone or another device.
Affected services
www.unitelogin.net
mt1.unitelogin.net
sipster.voiphighway.com