Back to overview
Resolved
911 Outage
Aug 27, 2026 at 3:15pm UTC
Affected services
www.unitelogin.net
mt1.unitelogin.net
Voiphighway.com
Pantechnicon
Resolved
Aug 27, 2026 at 3:15pm UTC
911 is currently experiencing a service-impacting outage.
Their teams are working diligently to resolve the issue.
Updates to follow once we hear more.
Affected services